Get IndexedDB closer to building for GTK+.
authormrobinson@webkit.org <mrobinson@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 18 May 2012 17:50:06 +0000 (17:50 +0000)
committermrobinson@webkit.org <mrobinson@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 18 May 2012 17:50:06 +0000 (17:50 +0000)
commite5b1264ad1804a7d458af6909e3fbf1ec8b3e62e
tree23fa91bccf6c685882f832e80d50804829c4b40f
parent6dc08766b78f7d199ce8ee814ed777ead1f50400
Get IndexedDB closer to building for GTK+.

Reviewed by Philippe Normand.

.:

* configure.ac: Make out the IndexedDB imply USE_LEVELDB, as LevelDB is the
only IndexedDB backend at the moment. Also mark IndexedDB as incomplete.

Source/WebCore:

No new tests. This is only a build fix.

* GNUmakefile.am: Add the appropriate option to enable LevelDB support.
* GNUmakefile.list.am: Add missing indexed database files to the source list.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@117605 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/WebCore/ChangeLog
Source/WebCore/GNUmakefile.am
Source/WebCore/GNUmakefile.list.am
configure.ac