[CMake][OpenVR] Linkage errors happen because only OpenVR is compiled with -stdlib...
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 26 Feb 2018 08:01:12 +0000 (08:01 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 26 Feb 2018 08:01:12 +0000 (08:01 +0000)
commite35b0818afdb187c99e8ab54dd0ece52270dcaeb
tree2b6a5e58f860915f05c0c7fdc46f72e674572d69
parent5993191212e040741492c5c9c9df075c8c2d92f4
[CMake][OpenVR] Linkage errors happen because only OpenVR is compiled with -stdlib=libc++ if Clang is used
https://bugs.webkit.org/show_bug.cgi?id=183116

Patch by Fujii Hironori <Hironori.Fujii@sony.com> on 2018-02-26
Reviewed by Žan Doberšek.

OpenVR has a option USE_LIBCXX to enable/disable that behavior. Let's disable it.

* Source/CMakeLists.txt: Added a option command for USE_LIBCXX to set OFF as default.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@228985 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/CMakeLists.txt