update-webkitgtk-flatpak fails if running with python2
authorHironori.Fujii@sony.com <Hironori.Fujii@sony.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 4 Jul 2018 03:14:42 +0000 (03:14 +0000)
committerHironori.Fujii@sony.com <Hironori.Fujii@sony.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 4 Jul 2018 03:14:42 +0000 (03:14 +0000)
commitd357edf8d5ce6c41fc7b3d9aff804bab5958a5b6
tree0c8bbbe0e59c6228bcdbcd68ea7d9b03701e900b
parentc32a0b278270f8fadf93f78772a4c7c278170a08
update-webkitgtk-flatpak fails if running with python2
https://bugs.webkit.org/show_bug.cgi?id=187240

Reviewed by Michael Catanzaro.

urllib.urlretrieve of Python2 sends invalid requests. Use
urllib2.urlopen instead.

* flatpak/flatpakutils.py: Import urllib2.urlopen for Python2,
urllib.request.urlopen for Python3.
(FlatpakRepo.repo_file): Copy the content of urlopen result to the
temporary file.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@233494 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Tools/ChangeLog
Tools/flatpak/flatpakutils.py