AX does not support HTML5 "required"
authorcfleizach@apple.com <cfleizach@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 6 Dec 2010 17:36:01 +0000 (17:36 +0000)
committercfleizach@apple.com <cfleizach@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 6 Dec 2010 17:36:01 +0000 (17:36 +0000)
commit9f538f0be296d0b0b72990514574e2aa14e3275e
treeb6556a9ea2bd31677259e7fec711d7b6e782f671
parent234d0f0a30d9a3b5af208ae238014969f401a521
AX does not support HTML5 "required"
https://bugs.webkit.org/show_bug.cgi?id=50507

Reviewed by Oliver Hunt.

WebCore:

Test: platform/mac/accessibility/html5-required-attribute.html

* accessibility/AccessibilityRenderObject.cpp:
(WebCore::AccessibilityRenderObject::isRequired):

LayoutTests:

* platform/mac/accessibility/html5-required-attribute-expected.txt: Added.
* platform/mac/accessibility/html5-required-attribute.html: Added.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@73374 268f45cc-cd09-0410-ab3c-d52691b4dbfc
LayoutTests/ChangeLog
LayoutTests/platform/mac/accessibility/html5-required-attribute-expected.txt [new file with mode: 0644]
LayoutTests/platform/mac/accessibility/html5-required-attribute.html [new file with mode: 0644]
WebCore/ChangeLog
WebCore/accessibility/AccessibilityRenderObject.cpp