[GStreamer] Bump required version to 1.8.3
authorphiln@webkit.org <philn@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 12 Jun 2018 12:07:16 +0000 (12:07 +0000)
committerphiln@webkit.org <philn@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 12 Jun 2018 12:07:16 +0000 (12:07 +0000)
commit9f2283482ccc622205ca5ffbf2e3f1dba52f0cc8
tree4704ae4ce4a1aa66fa38ba48b56e07d8870956ce
parent8e78abf103063084f442b3cff53f4acf037c2c24
[GStreamer] Bump required version to 1.8.3
https://bugs.webkit.org/show_bug.cgi?id=186558

Reviewed by Xabier Rodriguez-Calvar.

.:

* Source/cmake/GStreamerChecks.cmake: Bump to 1.8.3 which is the
version shipped in the current Ubuntu LTS we support (16.04).

Source/WebCore:

* platform/GStreamer.cmake: Remove useless file.
* platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp:
(webKitWebAudioSrcChangeState): Remove useless version check.
* platform/graphics/gstreamer/eme/GStreamerEMEUtilities.cpp:
Removed. createDecryptor() is dead code since the decryptors moved
to the MSE playback pipeline.
* platform/graphics/gstreamer/eme/GStreamerEMEUtilities.h:
(WebCore::GStreamerEMEUtilities::keySystemToUuid):

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@232749 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/WebCore/ChangeLog
Source/WebCore/platform/GStreamer.cmake
Source/WebCore/platform/audio/gstreamer/WebKitWebAudioSourceGStreamer.cpp
Source/WebCore/platform/graphics/gstreamer/eme/GStreamerEMEUtilities.cpp [deleted file]
Source/WebCore/platform/graphics/gstreamer/eme/GStreamerEMEUtilities.h
Source/cmake/GStreamerChecks.cmake