[WPE] Remove the possibility of installing the old WebKit2 C API
authoraperez@igalia.com <aperez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 11 Oct 2017 01:01:53 +0000 (01:01 +0000)
committeraperez@igalia.com <aperez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 11 Oct 2017 01:01:53 +0000 (01:01 +0000)
commit9dc043471e9aae63f6b05009cf7924a037ecfdfe
tree13faea9572893ba791f243324331636ba8c9a47d
parentb4452908c5a04d1be4292e04277121a88e6ffaf7
[WPE] Remove the possibility of installing the old WebKit2 C API
https://bugs.webkit.org/show_bug.cgi?id=178125

Reviewed by Michael Catanzaro.

.:

* Source/cmake/OptionsWPE.cmake: Remove definition of the EXPORT_DEPRECATED_WEBKIT2_C_API
build option.

Source/WebKit:

* PlatformWPE.cmake: Remove support for installing the deprecated C API.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@223162 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/WebKit/ChangeLog
Source/WebKit/PlatformWPE.cmake
Source/cmake/OptionsWPE.cmake