Remove unused linked-on-or-before-iOS5 check
authorachristensen@apple.com <achristensen@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 2 Oct 2018 20:26:15 +0000 (20:26 +0000)
committerachristensen@apple.com <achristensen@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 2 Oct 2018 20:26:15 +0000 (20:26 +0000)
commit710c13d4a736a2cc2786dc3d7ea81250f2ac74a9
tree43258f7aeb6c4c5067f72380c80e09d33c559238
parenta80cebc37207a4c956ed9adfe2e9124f2362502a
Remove unused linked-on-or-before-iOS5 check
https://bugs.webkit.org/show_bug.cgi?id=190164

Reviewed by Michael Saboff.

Source/WebCore:

If an app hasn't been updated since iOS5, it can't run supported iOS.
This value is also only checked in an uninstantiated template function.

* platform/URL.cpp:
(WebCore::enableURLSchemeCanonicalization): Deleted.
(WebCore::equal): Deleted.
* platform/URL.h:

Source/WebKitLegacy/ios:

* Misc/WebUIKitSupport.mm:
(WebKitInitialize):
(linkedOnOrAfterIOS5): Deleted.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@236763 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/WebCore/ChangeLog
Source/WebCore/platform/URL.cpp
Source/WebCore/platform/URL.h
Source/WebKitLegacy/ios/ChangeLog
Source/WebKitLegacy/ios/Misc/WebUIKitSupport.mm