2011-01-10 Daniel Bates <dbates@rim.com>
authordbates@webkit.org <dbates@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 11 Jan 2011 00:17:49 +0000 (00:17 +0000)
committerdbates@webkit.org <dbates@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 11 Jan 2011 00:17:49 +0000 (00:17 +0000)
commit3709b247f31b539942be22125be3d9aea21dfe55
treec2913e01c3e55c6f1f08da828fbbc4a5ec437809
parent5019769f6dd0a1618584b360a0dead089860b8e1
2011-01-10  Daniel Bates  <dbates@rim.com>

        Reviewed by Darin Adler.

        Use __builtin_expect when compiling using RVCT in GNU mode
        https://bugs.webkit.org/show_bug.cgi?id=51866

        We should only use __builtin_expect if we are compiling with GCC or RVCT 3 or higher in GNU mode
        as pointed out by Siddharth Mathur per <http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.dui0202h/Cjabddedbde.html>.

        * wtf/AlwaysInline.h:
        * wtf/Platform.h: Removed define WTF_COMPILER_RVCT4_OR_GREATER. Instead added macro
        function RVCT_VERSION_AT_LEAST so that we can test for an arbitrary minimum RVCT
        version.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@75447 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/JavaScriptCore/ChangeLog
Source/JavaScriptCore/wtf/AlwaysInline.h
Source/JavaScriptCore/wtf/Platform.h