Build should fail early is needed Perl modules are not installed
authortpopela@redhat.com <tpopela@redhat.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 14 Dec 2017 14:08:20 +0000 (14:08 +0000)
committertpopela@redhat.com <tpopela@redhat.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 14 Dec 2017 14:08:20 +0000 (14:08 +0000)
commit0fcfc77fe6e43207ebfd5557860afb1a687b131a
tree88ecdda8bffe48aaf9641036809732fbe3ad13ee
parent000630a0e065a71e6bbc373efb9b389d7d7a27f6
Build should fail early is needed Perl modules are not installed
https://bugs.webkit.org/show_bug.cgi?id=180137

Reviewed by Michael Catanzaro.

Don't finish the configure successfully if the required Perl modules
are not installed. Start to require modules that are needed for
WPE/GTK+ ports.

* Source/cmake/FindPerlModules.cmake: Copied from
https://github.com/KDE/kdelibs4support/blob/master/cmake/FindPerlModules.cmake
and made it WebKit style compliant.
* Source/cmake/WebKitCommon.cmake:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@225901 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/cmake/FindPerlModules.cmake [new file with mode: 0644]
Source/cmake/WebKitCommon.cmake