[WPE] API tests can't run in flatpak environment
authorphiln@webkit.org <philn@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 9 Jan 2019 10:59:45 +0000 (10:59 +0000)
committerphiln@webkit.org <philn@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 9 Jan 2019 10:59:45 +0000 (10:59 +0000)
commit0a1a9a56d2efd4dfa814add568f151a493f03d36
tree6046d638e27b763c61817c942ff27f7e7a0eb302
parentf93fb69269f0180fc2342e46447ac923e3be2c0b
[WPE] API tests can't run in flatpak environment
https://bugs.webkit.org/show_bug.cgi?id=193242

Reviewed by Michael Catanzaro.

* Scripts/run-wpe-tests: Add --wpe to arguments passed to
flatpakutils so that it knows which port it's dealing with.
* glib/common.py: Remove build_dir globals so that subsequent
calls actually take args into account.
(library_build_path):
(binary_build_path):

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@239767 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Tools/ChangeLog
Tools/Scripts/run-wpe-tests
Tools/glib/common.py