Unreviewed. Fix GTK+ build after r115314.
authorcarlosgc@webkit.org <carlosgc@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 26 Apr 2012 19:01:49 +0000 (19:01 +0000)
committercarlosgc@webkit.org <carlosgc@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 26 Apr 2012 19:01:49 +0000 (19:01 +0000)
commit08c24bc4ecd4e133d4f233aacafa9eb0f7faaead
tree8c48241f84e0e3a0cceab9cb08b97a02580e83c4
parent3e51251bd0de50d11debe34a6edd1fb8ffdf57fd
Unreviewed. Fix GTK+ build after r115314.

For some reason it fails while bulding GtkVersioning for WTR, but
it didn't fail neither in EWS nor in my laptop. We don't really
need GtkVersioning in WTR since it already depends on GTK+3
unconditionally.

* WebKitTestRunner/GNUmakefile.am: Remove GtkVersioning.c from
compilation.
* WebKitTestRunner/gtk/EventSenderProxyGtk.cpp:
(WTR::EventSenderProxy::createMouseButtonEvent): Use GTK+ 3 API
directly instead of getDefaultGDKPointerDevice() helper.
(WTR::EventSenderProxy::keyDown): Ditto.
(WTR::EventSenderProxy::mouseMoveTo): Ditto.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@115338 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Tools/ChangeLog
Tools/WebKitTestRunner/GNUmakefile.am
Tools/WebKitTestRunner/gtk/EventSenderProxyGtk.cpp