[GTK][WK2] WebKit2 does not build if gtk-unix-printing-3.0 is not available
authormrobinson@webkit.org <mrobinson@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 20 Feb 2012 08:38:05 +0000 (08:38 +0000)
committermrobinson@webkit.org <mrobinson@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 20 Feb 2012 08:38:05 +0000 (08:38 +0000)
commit00b803f095efe21493128a83912f2a0362a26f6d
tree316f6751045afc995355118aea35d62880884731
parent973b4270b3c795e957fb2f8d74e57ad7352d60a1
[GTK][WK2] WebKit2 does not build if gtk-unix-printing-3.0 is not available
https://bugs.webkit.org/show_bug.cgi?id=79011

Fix the build when gtk-unix-printing-3.0 is not present.

* UIProcess/API/gtk/WebKitPrintOperation.cpp:
(webkitPrintOperationRunDialog):
(webkitPrintOperationRunDialogForFrame):
* WebProcess/WebPage/gtk/WebPrintOperationGtk.cpp:
(WebKit::WebPrintOperationGtk::create):

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@108216 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/WebKit2/ChangeLog
Source/WebKit2/UIProcess/API/gtk/WebKitPrintOperation.cpp
Source/WebKit2/WebProcess/WebPage/gtk/WebPrintOperationGtk.cpp