2010-05-03 Abhishek Arya <inferno@chromium.org>
[WebKit-https.git] / autogen.sh
index 8f736c4..97beb20 100755 (executable)
@@ -8,20 +8,13 @@ test -z "$srcdir" && srcdir=.
 ORIGDIR=`pwd`
 cd $srcdir
 
+GTKDOCIZE_FLAGS="--copy"
 LIBTOOLIZE_FLAGS="--force --automake"
 ACLOCAL_FLAGS="-I autotools"
 AUTOMAKE_FLAGS="--foreign --add-missing"
 
 DIE=0
 
-(gtkdocize --version) < /dev/null > /dev/null 2>&1 || {
-    echo
-    echo "You must have gtkdocize installed to compile $PROJECT."
-    echo "Install the appropriate package for your distribution,"
-    echo "or get the source tarball at http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/"
-    DIE=1
-}
-
 (autoconf --version) < /dev/null > /dev/null 2>&1 || {
     echo
     echo "You must have autoconf installed to compile $PROJECT."
@@ -58,7 +51,7 @@ rm -rf $top_srcdir/autom4te.cache
 
 touch README INSTALL
 
-gtkdocize || exit $?
+gtkdocize $GTKDOCIZE_FLAGS > /dev/null 2>&1 || echo "Warning: not running gtk-docize."
 aclocal $ACLOCAL_FLAGS || exit $?
 $LIBTOOLIZE $LIBTOOLIZE_FLAGS || exit $?
 autoheader || exit $?