[chromium] Update win/linux pixel expectations for r90701 (part 12/12).
[WebKit-https.git] / autogen.sh
index 1c0fc61..23639e8 100755 (executable)
@@ -8,37 +8,16 @@ test -z "$srcdir" && srcdir=.
 ORIGDIR=`pwd`
 cd $srcdir
 
-DIE=0
-
-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have autoconf installed to compile $PROJECT."
-       echo "Install the appropriate package for your distribution,"
-       echo "or get the source tarball at http://ftp.gnu.org/gnu/autoconf/"
-       DIE=1
-}
-
-(automake --version) < /dev/null > /dev/null 2>&1 || {
-       echo
-       echo "You must have automake installed to compile $PROJECT."
-       echo "Install the appropriate package for your distribution,"
-       echo "or get the source tarball at http://ftp.gnu.org/gnu/automake/"
-       DIE=1
-}
-
-if test "$DIE" -eq 1; then
-       exit 1
-fi
-
-rm -rf $top_srcdir/autom4te.cache
+rm -f $top_srcdir/autom4te.cache
 
 touch README INSTALL
 
-aclocal || exit $?
-libtoolize --force || exit $?
-autoheader || exit $?
-automake --foreign --add-missing || exit $?
-autoconf || exit $?
+gtkdocize --copy > /dev/null 2>&1 || echo "Warning: not running gtk-docize."
+if test -z `which autoreconf`; then
+    echo "Error: autoreconf not found, please install it."
+    exit 1
+fi
+autoreconf --verbose --install -I Source/autotools $ACLOCAL_FLAGS|| exit $?
 
 cd $ORIGDIR || exit 1