[Qt][WK2] Set up plugin process on Unix
[WebKit-https.git] / Tools / qmake / mkspecs / features / features.prf
index d85c7dc..2ec07e0 100644 (file)
@@ -127,12 +127,11 @@ haveQt(5) {
     no_webkit2 {
         DEFINES += PLUGIN_ARCHITECTURE_UNSUPPORTED=1
     } else {
-        # Disable xlib plugins while they're in-process, because they crash
-        # as soon as an installed npapi plugin uses Qt 4.
-        false:contains(QT_CONFIG, xcb-xlib) {
+        contains(QT_CONFIG, xcb-xlib) {
             CONFIG += plugin_backend_xlib
             DEFINES += PLUGIN_ARCHITECTURE_X11=1 \
-                       PLUGIN_ARCHITECTURE_UNSUPPORTED=0
+                       PLUGIN_ARCHITECTURE_UNSUPPORTED=0 \
+                       ENABLE_PLUGIN_PROCESS=1
         } else {
             DEFINES += PLUGIN_ARCHITECTURE_UNSUPPORTED=1
         }