[EFL] Bump gstreamer version to 1.4.4
[WebKit-https.git] / Tools / efl / jhbuild.modules
index ee48870..2b6f9aa 100644 (file)
             md5sum="9c0cfef285d5c4a5c80d00904ddab380"/>
   </autotools>
 
-  <autotools id="gstreamer" autogen-sh="configure">
-    <branch repo="gstreamer"
-            module="gstreamer/gstreamer-1.2.1.tar.xz" version="1.2.1"
-            hash="sha256:a4523d2471bca6cd0059a32e3b042f50faa4dadc6439852af8b43ca3f17d1fc9"/>
-    <dependencies>
-        <dep package="glib"/>
-    </dependencies>
+  <autotools id="gstreamer" autogenargs="--disable-gtk-doc">
+    <branch module="gstreamer/gstreamer-1.4.4.tar.xz" version="1.4.4"
+            repo="gstreamer"
+            hash="sha256:f0e305d91a93d05bf9e332cd4256ca07d77f5186a4d73847b7ae6db218f2c237"
+            md5sum="98f4a6d45a28dd195144baef0244ba38"/>
   </autotools>
 
   <autotools id="gst-plugins-base"
              autogen-sh="autogen.sh"
-             autogenargs="--disable-examples --enable-theora --enable-vorbis">
+             autogenargs="--disable-examples --disable-gtk-doc">
     <dependencies>
       <dep package="gstreamer"/>
     </dependencies>
-    <branch repo="gstreamer"
-            module="gst-plugins-base/gst-plugins-base-1.2.1.tar.xz" version="1.2.1"
-            hash="sha256:de2444a5c150d4e4b680364d7c0414cd8b015d95b305ff65d65a17683379532f">
-        <patch file="gst-prevent-neon-check-in-configure-from-passing-under-aarch64.patch" strip="1"/>
+    <branch module="gst-plugins-base/gst-plugins-base-1.4.4.tar.xz" version="1.4.4"
+            repo="gstreamer"
+            hash="sha256:49cd9e8f23c416b1607b43837a09833fa03e0106929d81ead2ddfde6c0ade44b"
+            md5sum="0c42eca8f9e4efd56d2ce8e9249ce4a1">
     </branch>
   </autotools>
 
-  <autotools id="gst-plugins-good"
-             autogen-sh="configure"
-             autogenargs="--disable-examples --enable-pulse">
+  <autotools id="gst-plugins-good" autogenargs="--disable-examples --disable-soup --disable-gtk-doc">
     <dependencies>
-      <dep package="cairo"/>
       <dep package="gst-plugins-base"/>
     </dependencies>
-    <branch repo="gstreamer"
-            module="gst-plugins-good/gst-plugins-good-1.2.1.tar.xz" version="1.2.1"
-            hash="sha256:660fa02dbe01086fcf702d87acc0ba5dde2559d6a11ecf438874afe504c50517"/>
+
+    <branch module="gst-plugins-good/gst-plugins-good-1.4.4.tar.xz" version="1.4.4"
+            repo="gstreamer"
+            hash="sha256:2df90e99da45211c7b2525ae4ac34830a9e7784bd48c072c406c0cf014bdb277"
+            md5sum="673cf9276952bd3937dafd817c9ead2b">
+    </branch>
   </autotools>
 
-  <autotools id="gst-plugins-bad"
-             autogen-sh="configure"
-             autogenargs="--disable-examples --enable-faad --enable-mpg123">
+  <autotools id="gst-plugins-bad" autogenargs="--disable-examples --disable-gtk-doc">
     <dependencies>
       <dep package="gst-plugins-base"/>
     </dependencies>
-    <branch repo="gstreamer"
-            module="gst-plugins-bad/gst-plugins-bad-1.2.1.tar.xz" version="1.2.1"
-            hash="sha256:f33e7c81fcb742fe50b73ad87ef8a4baa7d6b59c5002a10bf63c8dee22404929"/>
+    <branch module="gst-plugins-bad/gst-plugins-bad-1.4.4.tar.xz" version="1.4.4"
+            repo="gstreamer"
+            hash="sha256:e41b36105c0a13a2cb1ff9f559714e839b82dc3841484cd664790fb7947e55c7"
+            md5sum="972c6e22dd2e44fcf0b04b9d810a56be">
+      <patch file="gst-plugins-bad-remove-gnustep-support.patch" strip="1"/>
+    </branch>
   </autotools>
 
-  <autotools id="gst-libav"
-             autogen-sh="configure"
-             autogenargs="--with-libav-extra-configure='--disable-yasm'">
+  <autotools id="gst-libav" autogenargs="--with-libav-extra-configure='--disable-yasm' --disable-gtk-doc">
     <dependencies>
       <dep package="gst-plugins-base"/>
     </dependencies>
-    <branch repo="gstreamer"
-            module="gst-libav/gst-libav-1.2.1.tar.xz" version="1.2.1"
-            hash="sha256:fd152b7aec56ae76ad58b9759913a8bfe1792bdf64f260d0acaba75b75076676">
+    <branch module="gst-libav/gst-libav-1.4.4.tar.xz" version="1.4.4"
+            repo="gstreamer"
+            hash="sha256:2ec7285e5ec6731963b0955487cceb9eb04e285ca682f3ef575996c068cde8aa"
+            md5sum="64a3e2cda2687132cadca4efdc63f3b4">
       <patch file="gst-libav.patch" strip="1"/>
     </branch>
-  </autotools> 
+  </autotools>
 
   <autotools id="libseccomp" autogen-sh="configure">
       <branch module="libseccomp/libseccomp-2.1.1/libseccomp-2.1.1.tar.gz" version="2.1.1"