Unreviewed, fix GTK/EFL build after r197575 and add mandatory GnuTLS dependency
[WebKit-https.git] / Source / cmake / OptionsGTK.cmake
index c35b1e1..54671fe 100644 (file)
@@ -33,6 +33,7 @@ set(INTROSPECTION_INSTALL_TYPELIBDIR "${LIB_INSTALL_DIR}/girepository-1.0")
 find_package(Cairo 1.10.2 REQUIRED)
 find_package(Fontconfig 2.8.0 REQUIRED)
 find_package(Freetype2 2.4.2 REQUIRED)
+find_package(GnuTLS 3.0.0 REQUIRED)
 find_package(GTK3 3.6.0 REQUIRED)
 find_package(GDK3 3.6.0 REQUIRED)
 find_package(HarfBuzz 0.9.2 REQUIRED)
@@ -326,13 +327,6 @@ if (ENABLE_SPELLCHECK)
     endif ()
 endif ()
 
-if (ENABLE_SUBTLE_CRYPTO)
-    find_package(GnuTLS 3.0.0)
-    if (NOT GNUTLS_FOUND)
-        message(FATAL_ERROR "GnuTLS is needed for ENABLE_SUBTLE_CRYPTO")
-    endif ()
-endif ()
-
 if (ENABLE_VIDEO OR ENABLE_WEB_AUDIO)
     set(GSTREAMER_COMPONENTS app pbutils)