Unreviewed, fix GTK/EFL build after r197575 and add mandatory GnuTLS dependency
[WebKit-https.git] / Source / cmake / OptionsEfl.cmake
index 8f21323..0a55cae 100644 (file)
@@ -145,6 +145,7 @@ WEBKIT_OPTION_END()
 # Begin to find necessary packages for EFL port.
 find_package(Cairo 1.10.2 REQUIRED)
 find_package(Fontconfig 2.8.0 REQUIRED)
+find_package(GnuTLS 3.0.0 REQUIRED)
 find_package(LibXml2 2.8.0 REQUIRED)
 find_package(LibXslt 1.1.7 REQUIRED)
 find_package(ICU REQUIRED)
@@ -289,10 +290,6 @@ if (ENABLE_FTL_JIT AND NOT WTF_CPU_X86_64 AND NOT DEVELOPER_MODE)
     message(FATAL_ERROR "FTL JIT is only available on X86_64 architecture.")
 endif ()
 
-if (ENABLE_SUBTLE_CRYPTO)
-    find_package(GnuTLS 3.0.0 REQUIRED)
-endif ()
-
 if (USE_LIBHYPHEN)
     find_package(Hyphen)
     if (NOT HYPHEN_FOUND)