[Cocoa] Add a way for Apple-internal clients to opt into recommended compatibility...
[WebKit-https.git] / Source / WebKit / UIProcess / API / APINavigationClient.h
index 1105780..021256e 100644 (file)
@@ -91,6 +91,7 @@ public:
     virtual void renderingProgressDidChange(WebKit::WebPageProxy&, OptionSet<WebCore::LayoutMilestone>) { }
 
     virtual void didReceiveAuthenticationChallenge(WebKit::WebPageProxy&, WebKit::AuthenticationChallengeProxy& challenge) { challenge.listener().completeChallenge(WebKit::AuthenticationChallengeDisposition::PerformDefaultHandling); }
+    virtual bool shouldBypassCompatibilityModeSafeguards() const { return false; }
 
     // FIXME: These function should not be part of this client.
     virtual bool processDidTerminate(WebKit::WebPageProxy&, WebKit::ProcessTerminationReason) { return false; }