[EFL] Build fix when compiling with GLES2 support enabled.
[WebKit-https.git] / Source / WebCore / platform / graphics / opengl / GLPlatformContext.cpp
index ced7bb8..bce0425 100644 (file)
 
 #include "NotImplemented.h"
 
 
 #include "NotImplemented.h"
 
-#if HAVE(GLX)
-#include <GL/glx.h>
-#endif
-
 namespace WebCore {
 
 #if USE(OPENGL_ES_2)
 namespace WebCore {
 
 #if USE(OPENGL_ES_2)
@@ -55,8 +51,7 @@ public:
     GLCurrentContextWrapper()
         : GLPlatformContext()
     {
     GLCurrentContextWrapper()
         : GLPlatformContext()
     {
-        // FIXME:: This is a workaround until support to build evas with EGL has been added.
-#if USE(GLX) || PLATFORM(EFL)
+#if USE(GLX)
         m_contextHandle = glXGetCurrentContext();
 #elif USE(EGL)
         m_contextHandle = eglGetCurrentContext();
         m_contextHandle = glXGetCurrentContext();
 #elif USE(EGL)
         m_contextHandle = eglGetCurrentContext();