Fix Qt build.
[WebKit-https.git] / configure.ac
1 AC_PREREQ(2.60)
2
3 m4_include([Source/autotools/Versions.m4])
4
5 AC_INIT([WebKitGTK],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
6 AC_CONFIG_MACRO_DIR([Source/autotools])
7 AC_CONFIG_AUX_DIR([Source/autotools])
8 AC_SUBST(ACLOCAL_AMFLAGS, "-I Source/autotools")
9 AC_CONFIG_HEADERS([autotoolsconfig.h])
10 AC_CONFIG_SRCDIR([Source/WebCore/config.h])
11
12 WEBKIT_MAJOR_VERSION=webkit_major_version
13 WEBKIT_MINOR_VERSION=webkit_minor_version
14 WEBKIT_MICRO_VERSION=webkit_micro_version
15 WEBKIT_USER_AGENT_MAJOR_VERSION=webkit_user_agent_major_version
16 WEBKIT_USER_AGENT_MINOR_VERSION=webkit_user_agent_minor_version
17 AC_SUBST(WEBKIT_MAJOR_VERSION)
18 AC_SUBST(WEBKIT_MINOR_VERSION)
19 AC_SUBST(WEBKIT_MICRO_VERSION)
20 AC_SUBST(WEBKIT_USER_AGENT_MAJOR_VERSION)
21 AC_SUBST(WEBKIT_USER_AGENT_MINOR_VERSION)
22 AC_DEFINE([USER_AGENT_GTK_MAJOR_VERSION], [webkit_user_agent_major_version], [The major version used in user agent string])
23 AC_DEFINE([USER_AGENT_GTK_MINOR_VERSION], [webkit_user_agent_minor_version], [The minor version used in user agent string])
24
25 m4_include([Source/autotools/CheckSystemAndBasicDependencies.m4])
26 m4_include([Source/autotools/SetupLibtool.m4])
27 m4_include([Source/autotools/ReadCommandLineArguments.m4])
28 m4_include([Source/autotools/FindDependencies.m4])
29 m4_include([Source/autotools/SetupCompilerFlags.m4])
30 m4_include([Source/autotools/SetupAutoconfHeader.m4])
31 m4_include([Source/autotools/SetupWebKitFeatures.m4])
32
33 # We would put AM_INIT_AUTOMAKE into SetupAutomake.m4, but seems to cause autoconf errors.
34 AM_INIT_AUTOMAKE([foreign subdir-objects dist-xz no-dist-gzip tar-ustar])
35 AM_MAINTAINER_MODE([enable])
36 m4_include([Source/autotools/SetupAutomake.m4])
37
38 ######################################################################################
39 # Processing of configuration files
40 ######################################################################################
41
42 AC_CONFIG_FILES([
43     GNUmakefile Source/WebCore/platform/gtk/po/POTFILES
44     Source/JavaScriptCore/javascriptcoregtk-${WEBKITGTK_API_VERSION}.pc:Source/JavaScriptCore/javascriptcoregtk.pc.in
45     JavaScriptCore-${WEBKITGTK_API_VERSION}.gir:Source/JavaScriptCore/JavaScriptCore.gir.in])
46
47 if test "$enable_webkit1" = "yes"; then
48     AC_CONFIG_FILES([
49         Source/WebKit/gtk/webkit/webkitversion.h
50         Source/WebKit/gtk/${WEBKITGTK_PC_NAME}-${WEBKITGTK_API_VERSION}.pc:Source/WebKit/gtk/webkit.pc.in])
51 fi
52
53 if test "$enable_webkit2" = "yes"; then
54     AC_CONFIG_FILES([
55         DerivedSources/WebKit2/webkit2gtk/webkit2/WebKitVersion.h:Source/WebKit2/UIProcess/API/gtk/WebKitVersion.h.in
56         Source/WebKit2/webkit2gtk-${WEBKITGTK_API_VERSION}.pc:Source/WebKit2/webkit2gtk.pc.in])
57 fi
58
59 m4_include([Source/autotools/PrintBuildConfiguration.m4])