[WinCairo] Update WinCairoRequirements
[WebKit-https.git] / Source / cmake / OptionsWinCairo.cmake
1 set(WTF_PLATFORM_WIN_CAIRO 1)
2
3 include(OptionsWin)
4
5 find_package(Cairo 1.14.10 REQUIRED)
6 find_package(CURL 7.56.1 REQUIRED)
7 find_package(JPEG 1.5.2 REQUIRED)
8 find_package(LibXml2 2.9.7 REQUIRED)
9 find_package(OpenSSL 2.0.0 REQUIRED)
10 find_package(PNG 1.6.34 REQUIRED)
11 find_package(Sqlite 3.21.0 REQUIRED)
12 find_package(ZLIB 1.2.11 REQUIRED)
13
14 if (ENABLE_XSLT)
15     find_package(LibXslt 1.1.32 REQUIRED)
16 endif ()
17
18 SET_AND_EXPOSE_TO_BUILD(USE_CAIRO ON)
19 SET_AND_EXPOSE_TO_BUILD(USE_CF ON)
20
21 set(USE_CURL 1)
22 set(USE_ICU_UNICODE 1)
23 set(USE_TEXTURE_MAPPER_GL 1)
24
25 set(ENABLE_GRAPHICS_CONTEXT_3D 1)
26
27 set(COREFOUNDATION_LIBRARY CFlite)
28
29 add_definitions(-DWTF_PLATFORM_WIN_CAIRO=1)