[WPE][GTK] Bump minimum versions of GLib, GTK, libsoup, ATK, GStreamer, and Cairo
[WebKit-https.git] / Source / cmake / OptionsGTK.cmake
1 include(GNUInstallDirs)
2 include(VersioningUtils)
3
4 SET_PROJECT_VERSION(2 25 2)
5 set(WEBKITGTK_API_VERSION 4.0)
6
7 CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(WEBKIT 75 1 38)
8 CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(JAVASCRIPTCORE 32 1 14)
9
10 # These are shared variables, but we special case their definition so that we can use the
11 # CMAKE_INSTALL_* variables that are populated by the GNUInstallDirs macro.
12 set(LIB_INSTALL_DIR "${CMAKE_INSTALL_FULL_LIBDIR}" CACHE PATH "Absolute path to library installation directory")
13 set(EXEC_INSTALL_DIR "${CMAKE_INSTALL_FULL_BINDIR}" CACHE PATH "Absolute path to executable installation directory")
14 set(LIBEXEC_INSTALL_DIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/webkit2gtk-${WEBKITGTK_API_VERSION}" CACHE PATH "Absolute path to install executables executed by the library")
15
16 set(WEBKITGTK_HEADER_INSTALL_DIR "${CMAKE_INSTALL_INCLUDEDIR}/webkitgtk-${WEBKITGTK_API_VERSION}")
17 set(INTROSPECTION_INSTALL_GIRDIR "${CMAKE_INSTALL_FULL_DATADIR}/gir-1.0")
18 set(INTROSPECTION_INSTALL_TYPELIBDIR "${LIB_INSTALL_DIR}/girepository-1.0")
19
20 find_package(Cairo 1.14.0 REQUIRED)
21 find_package(Fontconfig 2.8.0 REQUIRED)
22 find_package(Freetype 2.4.2 REQUIRED)
23 find_package(LibGcrypt 1.6.0 REQUIRED)
24 find_package(GLIB 2.44.0 REQUIRED COMPONENTS gio gio-unix gobject gthread gmodule)
25 find_package(GTK3 3.22.0 REQUIRED)
26 find_package(GDK3 3.22.0 REQUIRED)
27 find_package(HarfBuzz 0.9.2 REQUIRED)
28 find_package(ICU REQUIRED COMPONENTS data i18n uc)
29 find_package(JPEG REQUIRED)
30 find_package(LibSoup 2.54.0 REQUIRED)
31 find_package(LibXml2 2.8.0 REQUIRED)
32 find_package(PNG REQUIRED)
33 find_package(Sqlite REQUIRED)
34 find_package(Threads REQUIRED)
35 find_package(ZLIB REQUIRED)
36 find_package(ATK 2.16.0 REQUIRED)
37 find_package(WebP REQUIRED)
38 find_package(ATSPI 2.5.3)
39 find_package(EGL)
40 find_package(GTKUnixPrint)
41 find_package(OpenGL)
42 find_package(OpenGLES2)
43
44 WEBKIT_OPTION_BEGIN()
45
46 include(GStreamerDefinitions)
47
48 SET_AND_EXPOSE_TO_BUILD(USE_ATK TRUE)
49 SET_AND_EXPOSE_TO_BUILD(USE_CAIRO TRUE)
50 SET_AND_EXPOSE_TO_BUILD(USE_XDGMIME TRUE)
51 SET_AND_EXPOSE_TO_BUILD(USE_GCRYPT TRUE)
52
53 if (WTF_CPU_ARM OR WTF_CPU_MIPS)
54     SET_AND_EXPOSE_TO_BUILD(USE_CAPSTONE ${DEVELOPER_MODE})
55 endif ()
56
57 # For old versions of HarfBuzz that do not expose an API for the OpenType MATH
58 # table, we enable our own code to parse that table.
59 if ("${PC_HARFBUZZ_VERSION}" VERSION_LESS "1.3.3")
60     add_definitions(-DENABLE_OPENTYPE_MATH=1)
61 endif ()
62
63 # Set the default value for ENABLE_GLES2 automatically.
64 # We are not enabling or disabling automatically a feature here, because
65 # the feature is by default always on (ENABLE_OPENGL=ON).
66 # What we select here automatically is if we use OPENGL (ENABLE_GLES2=OFF)
67 # or OPENGLES2 (ENABLE_GLES2=ON) for building the feature.
68 set(ENABLE_GLES2_DEFAULT OFF)
69
70 if (NOT OPENGL_FOUND AND OPENGLES2_FOUND)
71     set(ENABLE_GLES2_DEFAULT ON)
72 endif ()
73
74 # Public options specific to the GTK port. Do not add any options here unless
75 # there is a strong reason we should support changing the value of the option,
76 # and the option is not relevant to any other WebKit ports.
77 WEBKIT_OPTION_DEFINE(ENABLE_GLES2 "Whether to enable OpenGL ES 2.0." PUBLIC ${ENABLE_GLES2_DEFAULT})
78 WEBKIT_OPTION_DEFINE(ENABLE_GTKDOC "Whether or not to use generate gtkdoc." PUBLIC OFF)
79 WEBKIT_OPTION_DEFINE(ENABLE_INTROSPECTION "Whether to enable GObject introspection." PUBLIC ON)
80 WEBKIT_OPTION_DEFINE(ENABLE_OPENGL "Whether to use OpenGL." PUBLIC ON)
81 WEBKIT_OPTION_DEFINE(ENABLE_QUARTZ_TARGET "Whether to enable support for the Quartz windowing target." PUBLIC ${GTK3_SUPPORTS_QUARTZ})
82 WEBKIT_OPTION_DEFINE(ENABLE_X11_TARGET "Whether to enable support for the X11 windowing target." PUBLIC ${GTK3_SUPPORTS_X11})
83 WEBKIT_OPTION_DEFINE(ENABLE_WAYLAND_TARGET "Whether to enable support for the Wayland windowing target." PUBLIC ${GTK3_SUPPORTS_WAYLAND})
84 WEBKIT_OPTION_DEFINE(USE_LIBNOTIFY "Whether to enable the default web notification implementation." PUBLIC ON)
85 WEBKIT_OPTION_DEFINE(USE_LIBHYPHEN "Whether to enable the default automatic hyphenation implementation." PUBLIC ON)
86 WEBKIT_OPTION_DEFINE(USE_LIBSECRET "Whether to enable the persistent credential storage using libsecret." PUBLIC ON)
87 WEBKIT_OPTION_DEFINE(USE_OPENJPEG "Whether to enable support for JPEG2000 images." PUBLIC ON)
88 WEBKIT_OPTION_DEFINE(USE_WOFF2 "Whether to enable support for WOFF2 Web Fonts." PUBLIC ON)
89 WEBKIT_OPTION_DEFINE(USE_WPE_RENDERER "Whether to enable WPE rendering" PUBLIC ON)
90
91 # Private options specific to the GTK port. Changing these options is
92 # completely unsupported. They are intended for use only by WebKit developers.
93 WEBKIT_OPTION_DEFINE(USE_OPENVR "Whether to use OpenVR as WebVR backend." PRIVATE OFF)
94
95 # FIXME: Can we use cairo-glesv2 to avoid this conflict?
96 WEBKIT_OPTION_CONFLICT(ENABLE_ACCELERATED_2D_CANVAS ENABLE_GLES2)
97
98 WEBKIT_OPTION_DEPEND(ENABLE_3D_TRANSFORMS ENABLE_OPENGL)
99 WEBKIT_OPTION_DEPEND(ENABLE_ACCELERATED_2D_CANVAS ENABLE_OPENGL)
100 WEBKIT_OPTION_DEPEND(ENABLE_ASYNC_SCROLLING ENABLE_OPENGL)
101 WEBKIT_OPTION_DEPEND(ENABLE_GLES2 ENABLE_OPENGL)
102 WEBKIT_OPTION_DEPEND(ENABLE_WEBGL ENABLE_OPENGL)
103 WEBKIT_OPTION_DEPEND(USE_WPE_RENDERER ENABLE_OPENGL)
104 WEBKIT_OPTION_DEPEND(USE_WPE_RENDERER ENABLE_WAYLAND_TARGET)
105
106 SET_AND_EXPOSE_TO_BUILD(ENABLE_DEVELOPER_MODE ${DEVELOPER_MODE})
107 if (DEVELOPER_MODE)
108     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MINIBROWSER PUBLIC ON)
109     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_API_TESTS PRIVATE ON)
110 else ()
111     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MINIBROWSER PUBLIC OFF)
112     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_API_TESTS PRIVATE OFF)
113 endif ()
114
115 if (CMAKE_SYSTEM_NAME MATCHES "Linux")
116     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEMORY_SAMPLER PRIVATE ON)
117     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_RESOURCE_USAGE PRIVATE ON)
118 else ()
119     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEMORY_SAMPLER PRIVATE OFF)
120     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_RESOURCE_USAGE PRIVATE OFF)
121 endif ()
122
123 if (CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT EXISTS "/.flatpak-info")
124     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_BUBBLEWRAP_SANDBOX PUBLIC ON)
125 else ()
126     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_BUBBLEWRAP_SANDBOX PUBLIC OFF)
127 endif ()
128
129 # Enable variation fonts when cairo >= 1.16, fontconfig >= 2.13.0, freetype >= 2.9.0 and harfbuzz >= 1.4.2.
130 if (("${PC_CAIRO_VERSION}" VERSION_GREATER "1.16.0" OR "${PC_CAIRO_VERSION}" STREQUAL "1.16.0")
131     AND ("${PC_FONTCONFIG_VERSION}" VERSION_GREATER "2.13.0" OR "${PC_FONTCONFIG_VERSION}" STREQUAL "2.13.0")
132     AND ("${FREETYPE_VERSION_STRING}" VERSION_GREATER "2.9.0" OR "${FREETYPE_VERSION_STRING}" STREQUAL "2.9.0")
133     AND ("${PC_HARFBUZZ_VERSION}" VERSION_GREATER "1.4.2" OR "${PC_HARFBUZZ_VERSION}" STREQUAL "1.4.2"))
134     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_VARIATION_FONTS PRIVATE ON)
135 endif ()
136
137 # Public options shared with other WebKit ports. Do not add any options here
138 # without approval from a GTK reviewer. There must be strong reason to support
139 # changing the value of the option.
140 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ACCELERATED_2D_CANVAS PUBLIC OFF)
141 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ASYNC_SCROLLING PRIVATE OFF)
142 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DRAG_SUPPORT PUBLIC ON)
143 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ICONDATABASE PUBLIC ON)
144 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SPELLCHECK PUBLIC ON)
145 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_TOUCH_EVENTS PUBLIC ON)
146 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_WEB_CRYPTO PUBLIC ON)
147 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_WEBDRIVER PUBLIC ON)
148
149 # Private options shared with other WebKit ports. Add options here when
150 # we need a value different from the default defined in WebKitFeatures.cmake.
151 # Changing these options is completely unsupported.
152 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_CONTENT_EXTENSIONS PRIVATE ON)
153 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DARK_MODE_CSS PRIVATE ON)
154 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DOWNLOAD_ATTRIBUTE PRIVATE ON)
155 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ENCRYPTED_MEDIA PRIVATE ${ENABLE_EXPERIMENTAL_FEATURES})
156 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_FTPDIR PRIVATE OFF)
157 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_INPUT_TYPE_COLOR PRIVATE ON)
158 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEDIA_STREAM PRIVATE ${ENABLE_EXPERIMENTAL_FEATURES})
159 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MHTML PRIVATE ON)
160 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_NETWORK_CACHE_SPECULATIVE_REVALIDATION PRIVATE ON)
161 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SERVICE_WORKER PRIVATE ${ENABLE_EXPERIMENTAL_FEATURES})
162 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SHAREABLE_RESOURCE PUBLIC ON)
163 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_WEB_RTC PRIVATE ${ENABLE_EXPERIMENTAL_FEATURES})
164
165 include(GStreamerDependencies)
166
167 # Finalize the value for all options. Do not attempt to use an option before
168 # this point, and do not attempt to change any option after this point.
169 WEBKIT_OPTION_END()
170
171 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_QUARTZ ${ENABLE_QUARTZ_TARGET})
172 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_X11 ${ENABLE_X11_TARGET})
173 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_WAYLAND ${ENABLE_WAYLAND_TARGET})
174
175 if (ENABLE_NETSCAPE_PLUGIN_API)
176     # MOZ_X11 and XP_UNIX are required by npapi.h. Their value is not checked;
177     # only their definedness is. They should only be defined in the true case.
178     if (ENABLE_X11_TARGET)
179         SET_AND_EXPOSE_TO_BUILD(MOZ_X11 1)
180     endif ()
181     SET_AND_EXPOSE_TO_BUILD(XP_UNIX 1)
182 endif ()
183
184 set(ENABLE_PLUGIN_PROCESS ${ENABLE_NETSCAPE_PLUGIN_API})
185
186 add_definitions(-DBUILDING_GTK__=1)
187 add_definitions(-DGETTEXT_PACKAGE="WebKit2GTK-${WEBKITGTK_API_VERSION}")
188 add_definitions(-DWEBKITGTK_API_VERSION_STRING="${WEBKITGTK_API_VERSION}")
189 add_definitions(-DJSC_GLIB_API_ENABLED)
190
191 set(GTK_LIBRARIES ${GTK3_LIBRARIES})
192 set(GTK_INCLUDE_DIRS ${GTK3_INCLUDE_DIRS})
193 set(GDK_LIBRARIES ${GDK3_LIBRARIES})
194 set(GDK_INCLUDE_DIRS ${GDK3_INCLUDE_DIRS})
195
196 SET_AND_EXPOSE_TO_BUILD(HAVE_GTK_UNIX_PRINTING ${GTKUnixPrint_FOUND})
197 SET_AND_EXPOSE_TO_BUILD(HAVE_OS_DARK_MODE_SUPPORT 1)
198
199 if (USE_WPE_RENDERER)
200     find_package(WPE 1.3.0)
201     if (NOT WPE_FOUND)
202         message(FATAL_ERROR "libwpe is required for USE_WPE_RENDERER")
203     endif ()
204
205     find_package(WPEBackend-fdo 1.3.1)
206     if (NOT WPEBACKEND_FDO_FOUND)
207         message(FATAL_ERROR "WPEBackend-fdo is required for USE_WPE_RENDERER")
208     endif ()
209 endif ()
210
211 if (ENABLE_XSLT)
212     find_package(LibXslt 1.1.7 REQUIRED)
213 endif ()
214
215 if (ENABLE_ACCELERATED_2D_CANVAS)
216     if (GLX_FOUND)
217         list(APPEND CAIROGL_COMPONENTS cairo-glx)
218     endif ()
219     if (EGL_FOUND)
220         list(APPEND CAIROGL_COMPONENTS cairo-egl)
221     endif ()
222
223     find_package(CairoGL 1.10.2 COMPONENTS ${CAIROGL_COMPONENTS})
224     if (NOT CAIROGL_FOUND)
225         message(FATAL_ERROR "CairoGL is needed for ENABLE_ACCELERATED_2D_CANVAS")
226     endif ()
227 endif ()
228
229 if (USE_LIBSECRET)
230     find_package(Libsecret)
231     if (NOT LIBSECRET_FOUND)
232         message(FATAL_ERROR "libsecret is needed for USE_LIBSECRET")
233     endif ()
234 endif ()
235
236 if (ENABLE_INTROSPECTION)
237     find_package(GObjectIntrospection)
238     if (NOT INTROSPECTION_FOUND)
239         message(FATAL_ERROR "GObjectIntrospection is needed for ENABLE_INTROSPECTION.")
240     endif ()
241 endif ()
242
243 if (ENABLE_WEB_CRYPTO)
244     find_package(Libtasn1 REQUIRED)
245     if (NOT LIBTASN1_FOUND)
246         message(FATAL_ERROR "libtasn1 is required to enable Web Crypto API support.")
247     endif ()
248     if (LIBGCRYPT_VERSION VERSION_LESS 1.7.0)
249         message(FATAL_ERROR "libgcrypt 1.7.0 is required to enable Web Crypto API support.")
250     endif ()
251 endif ()
252
253 if (ENABLE_WEBDRIVER)
254     SET_AND_EXPOSE_TO_BUILD(ENABLE_WEBDRIVER_KEYBOARD_INTERACTIONS ON)
255     SET_AND_EXPOSE_TO_BUILD(ENABLE_WEBDRIVER_MOUSE_INTERACTIONS ON)
256     SET_AND_EXPOSE_TO_BUILD(ENABLE_WEBDRIVER_TOUCH_INTERACTIONS OFF)
257 endif ()
258
259 SET_AND_EXPOSE_TO_BUILD(USE_TEXTURE_MAPPER TRUE)
260
261 if (ENABLE_OPENGL)
262     # ENABLE_OPENGL is true if either USE_OPENGL or ENABLE_GLES2 is true.
263     # But USE_OPENGL is the opposite of ENABLE_GLES2.
264     if (ENABLE_GLES2)
265         find_package(OpenGLES2 REQUIRED)
266         SET_AND_EXPOSE_TO_BUILD(USE_OPENGL_ES TRUE)
267
268         if (NOT EGL_FOUND)
269             message(FATAL_ERROR "EGL is needed for ENABLE_GLES2.")
270         endif ()
271     else ()
272         if (NOT OPENGL_FOUND)
273             message(FATAL_ERROR "Either OpenGL or OpenGLES2 is needed for ENABLE_OPENGL.")
274         endif ()
275         SET_AND_EXPOSE_TO_BUILD(USE_OPENGL TRUE)
276     endif ()
277
278     if (NOT EGL_FOUND AND (NOT ENABLE_X11_TARGET OR NOT GLX_FOUND))
279         message(FATAL_ERROR "Either GLX or EGL is needed for ENABLE_OPENGL.")
280     endif ()
281
282     SET_AND_EXPOSE_TO_BUILD(ENABLE_GRAPHICS_CONTEXT_3D TRUE)
283
284     SET_AND_EXPOSE_TO_BUILD(USE_TEXTURE_MAPPER_GL TRUE)
285
286     SET_AND_EXPOSE_TO_BUILD(USE_EGL ${EGL_FOUND})
287
288     if (ENABLE_X11_TARGET AND GLX_FOUND AND USE_OPENGL)
289         SET_AND_EXPOSE_TO_BUILD(USE_GLX TRUE)
290     endif ()
291
292     SET_AND_EXPOSE_TO_BUILD(USE_COORDINATED_GRAPHICS TRUE)
293     SET_AND_EXPOSE_TO_BUILD(USE_NICOSIA TRUE)
294 endif ()
295
296 if (ENABLE_SPELLCHECK)
297     find_package(Enchant)
298     if (NOT PC_ENCHANT_FOUND)
299         message(FATAL_ERROR "Enchant is needed for ENABLE_SPELLCHECK")
300     endif ()
301 endif ()
302
303 if (ENABLE_QUARTZ_TARGET)
304     if (NOT GTK3_SUPPORTS_QUARTZ)
305         message(FATAL_ERROR "Recompile GTK with Quartz backend to use ENABLE_QUARTZ_TARGET")
306     endif ()
307 endif ()
308
309 if (ENABLE_X11_TARGET)
310     if (NOT GTK3_SUPPORTS_X11)
311         message(FATAL_ERROR "Recompile GTK with X11 backend to use ENABLE_X11_TARGET")
312     endif ()
313
314     find_package(X11 REQUIRED)
315     if (NOT X11_Xcomposite_FOUND)
316         message(FATAL_ERROR "libXcomposite is required for ENABLE_X11_TARGET")
317     elseif (NOT X11_Xdamage_FOUND)
318         message(FATAL_ERROR "libXdamage is required for ENABLE_X11_TARGET")
319     elseif (NOT X11_Xrender_FOUND)
320         message(FATAL_ERROR "libXrender is required for ENABLE_X11_TARGET")
321     elseif (NOT X11_Xt_FOUND)
322         message(FATAL_ERROR "libXt is required for ENABLE_X11_TARGET")
323     endif ()
324 endif ()
325
326 if (ENABLE_WAYLAND_TARGET)
327     if (NOT GTK3_SUPPORTS_WAYLAND)
328         message(FATAL_ERROR "Recompile GTK with Wayland backend to use ENABLE_WAYLAND_TARGET")
329     endif ()
330
331     if (NOT EGL_FOUND)
332         message(FATAL_ERROR "EGL is required to use ENABLE_WAYLAND_TARGET")
333     endif ()
334
335     find_package(Wayland REQUIRED)
336 endif ()
337
338 if (USE_LIBNOTIFY)
339     find_package(LibNotify)
340     if (NOT LIBNOTIFY_FOUND)
341        message(FATAL_ERROR "libnotify is needed for USE_LIBNOTIFY.")
342     endif ()
343 endif ()
344
345 if (USE_LIBHYPHEN)
346     find_package(Hyphen)
347     if (NOT HYPHEN_FOUND)
348        message(FATAL_ERROR "libhyphen is needed for USE_LIBHYPHEN.")
349     endif ()
350 endif ()
351
352 if (USE_OPENJPEG)
353     find_package(OpenJPEG)
354     if (NOT OpenJPEG_FOUND)
355         message(FATAL_ERROR "libopenjpeg is needed for USE_OPENJPEG.")
356     endif ()
357     if ("${OPENJPEG_MAJOR_VERSION}.${OPENJPEG_MINOR_VERSION}.${OPENJPEG_BUILD_VERSION}" VERSION_LESS "2.2.0")
358         message(FATAL_ERROR "libopenjpeg 2.2.0 is required for USE_OPENJPEG.")
359     endif ()
360 endif ()
361
362 if (USE_WOFF2)
363     find_package(WOFF2Dec 1.0.2)
364     if (NOT WOFF2DEC_FOUND)
365        message(FATAL_ERROR "libwoff2dec is needed for USE_WOFF2.")
366     endif ()
367 endif ()
368
369 # https://bugs.webkit.org/show_bug.cgi?id=182247
370 if (ENABLED_COMPILER_SANITIZERS)
371     set(ENABLE_INTROSPECTION OFF)
372 endif ()
373
374 # Override the cached variables, gtk-doc and gobject-introspection do not really work when cross-building.
375 if (CMAKE_CROSSCOMPILING)
376     set(ENABLE_GTKDOC OFF)
377     set(ENABLE_INTROSPECTION OFF)
378 endif ()
379
380 # Override the cached variable, gtk-doc does not really work when building on Mac.
381 if (APPLE)
382     set(ENABLE_GTKDOC OFF)
383 endif ()
384
385 set(DERIVED_SOURCES_WEBKITGTK_DIR ${DERIVED_SOURCES_DIR}/webkitgtk)
386 set(DERIVED_SOURCES_WEBKITGTK_API_DIR ${DERIVED_SOURCES_WEBKITGTK_DIR}/webkit)
387 set(DERIVED_SOURCES_WEBKIT2GTK_DIR ${DERIVED_SOURCES_DIR}/webkit2gtk)
388 set(DERIVED_SOURCES_WEBKIT2GTK_API_DIR ${DERIVED_SOURCES_WEBKIT2GTK_DIR}/webkit2)
389 set(DERIVED_SOURCES_JAVASCRIPCOREGTK_DIR ${DERIVED_SOURCES_JAVASCRIPTCORE_DIR}/javascriptcoregtk)
390 set(DERIVED_SOURCES_JAVASCRIPCORE_GLIB_API_DIR ${DERIVED_SOURCES_JAVASCRIPTCORE_DIR}/javascriptcoregtk/jsc)
391 set(FORWARDING_HEADERS_WEBKIT2GTK_DIR ${FORWARDING_HEADERS_DIR}/webkit2gtk)
392 set(FORWARDING_HEADERS_WEBKIT2GTK_EXTENSION_DIR ${FORWARDING_HEADERS_DIR}/webkit2gtk-webextension)
393
394 set(JavaScriptCore_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/JavaScriptCore/javascriptcoregtk-${WEBKITGTK_API_VERSION}.pc)
395 set(WebKit2_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/WebKit/webkit2gtk-${WEBKITGTK_API_VERSION}.pc)
396 set(WebKit2WebExtension_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/WebKit/webkit2gtk-web-extension-${WEBKITGTK_API_VERSION}.pc)
397
398 set(JavaScriptCore_LIBRARY_TYPE SHARED)
399 set(SHOULD_INSTALL_JS_SHELL ON)
400
401 # Add a typelib file to the list of all typelib dependencies. This makes it easy to
402 # expose a 'gir' target with all gobject-introspection files.
403 macro(ADD_TYPELIB typelib)
404     if (ENABLE_INTROSPECTION)
405         get_filename_component(target_name ${typelib} NAME_WE)
406         add_custom_target(${target_name}-gir ALL DEPENDS ${typelib})
407         list(APPEND GObjectIntrospectionTargets ${target_name}-gir)
408         set(GObjectIntrospectionTargets ${GObjectIntrospectionTargets} PARENT_SCOPE)
409     endif ()
410 endmacro()
411
412 # CMake does not automatically add --whole-archive when building shared objects from
413 # a list of convenience libraries. This can lead to missing symbols in the final output.
414 # We add --whole-archive to all libraries manually to prevent the linker from trimming
415 # symbols that we actually need later. With ld64 on darwin, we use -all_load instead.
416 macro(ADD_WHOLE_ARCHIVE_TO_LIBRARIES _list_name)
417     if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
418         list(APPEND ${_list_name} -Wl,-all_load)
419     else ()
420         set(_tmp)
421         foreach (item IN LISTS ${_list_name})
422             if ("${item}" STREQUAL "PRIVATE" OR "${item}" STREQUAL "PUBLIC")
423                 list(APPEND _tmp "${item}")
424             else ()
425                 list(APPEND _tmp -Wl,--whole-archive "${item}" -Wl,--no-whole-archive)
426             endif ()
427         endforeach ()
428         set(${_list_name} ${_tmp})
429     endif ()
430 endmacro()
431
432 include(BubblewrapSandboxChecks)
433 include(GStreamerChecks)