[CMake] Raise minimum CMake requirement
[WebKit-https.git] / Source / cmake / OptionsGTK.cmake
1 include(GNUInstallDirs)
2
3 set(PROJECT_VERSION_MAJOR 2)
4 set(PROJECT_VERSION_MINOR 17)
5 set(PROJECT_VERSION_MICRO 4)
6 set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_MICRO})
7 set(WEBKITGTK_API_VERSION 4.0)
8
9 # Libtool library version, not to be confused with API version.
10 # See http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html
11 macro(CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE library_name current revision age)
12     math(EXPR ${library_name}_VERSION_MAJOR "${current} - ${age}")
13     set(${library_name}_VERSION_MINOR ${age})
14     set(${library_name}_VERSION_MICRO ${revision})
15     set(${library_name}_VERSION ${${library_name}_VERSION_MAJOR}.${age}.${revision})
16 endmacro()
17 CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(WEBKIT 60 0 23)
18 CALCULATE_LIBRARY_VERSIONS_FROM_LIBTOOL_TRIPLE(JAVASCRIPTCORE 24 4 6)
19
20 # These are shared variables, but we special case their definition so that we can use the
21 # CMAKE_INSTALL_* variables that are populated by the GNUInstallDirs macro.
22 set(LIB_INSTALL_DIR "${CMAKE_INSTALL_FULL_LIBDIR}" CACHE PATH "Absolute path to library installation directory")
23 set(EXEC_INSTALL_DIR "${CMAKE_INSTALL_FULL_BINDIR}" CACHE PATH "Absolute path to executable installation directory")
24 set(LIBEXEC_INSTALL_DIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/webkit2gtk-${WEBKITGTK_API_VERSION}" CACHE PATH "Absolute path to install executables executed by the library")
25
26 set(DATA_BUILD_DIR "${CMAKE_BINARY_DIR}/share/${WebKit_OUTPUT_NAME}")
27 set(DATA_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/webkitgtk-${WEBKITGTK_API_VERSION}")
28 set(WEBKITGTK_HEADER_INSTALL_DIR "${CMAKE_INSTALL_INCLUDEDIR}/webkitgtk-${WEBKITGTK_API_VERSION}")
29 set(INTROSPECTION_INSTALL_GIRDIR "${CMAKE_INSTALL_FULL_DATADIR}/gir-1.0")
30 set(INTROSPECTION_INSTALL_TYPELIBDIR "${LIB_INSTALL_DIR}/girepository-1.0")
31
32 find_package(Cairo 1.10.2 REQUIRED)
33 find_package(Fontconfig 2.8.0 REQUIRED)
34 find_package(Freetype2 2.4.2 REQUIRED)
35 find_package(LibGcrypt 1.6.0 REQUIRED)
36 find_package(GTK3 3.6.0 REQUIRED)
37 find_package(GDK3 3.6.0 REQUIRED)
38 find_package(HarfBuzz 0.9.2 REQUIRED)
39 find_package(ICU REQUIRED)
40 find_package(JPEG REQUIRED)
41 find_package(LibSoup 2.42.0 REQUIRED)
42 find_package(LibXml2 2.8.0 REQUIRED)
43 find_package(PNG REQUIRED)
44 find_package(Sqlite REQUIRED)
45 find_package(Threads REQUIRED)
46 find_package(ZLIB REQUIRED)
47 find_package(ATK REQUIRED)
48 find_package(WebP REQUIRED)
49 find_package(ATSPI 2.5.3)
50 find_package(EGL)
51 find_package(GTKUnixPrint)
52 find_package(OpenGL)
53 find_package(OpenGLES2)
54
55 WEBKIT_OPTION_BEGIN()
56
57 set(USE_CAIRO ON)
58 set(USE_WOFF2 ON)
59 set(USE_XDGMIME ON)
60
61 # For old versions of HarfBuzz that do not expose an API for the OpenType MATH
62 # table, we enable our own code to parse that table.
63 if ("${PC_HARFBUZZ_VERSION}" VERSION_LESS "1.3.3")
64     add_definitions(-DENABLE_OPENTYPE_MATH=1)
65 endif ()
66
67 # Set the default value for ENABLE_GLES2 automatically.
68 # We are not enabling or disabling automatically a feature here, because
69 # the feature is by default always on (ENABLE_OPENGL=ON).
70 # What we select here automatically is if we use OPENGL (ENABLE_GLES2=OFF)
71 # or OPENGLES2 (ENABLE_GLES2=ON) for building the feature.
72 set(ENABLE_GLES2_DEFAULT OFF)
73
74 if (NOT OPENGL_FOUND AND OPENGLES2_FOUND)
75     set(ENABLE_GLES2_DEFAULT ON)
76 endif ()
77
78 # Public options specific to the GTK+ port. Do not add any options here unless
79 # there is a strong reason we should support changing the value of the option,
80 # and the option is not relevant to any other WebKit ports.
81 WEBKIT_OPTION_DEFINE(ENABLE_GLES2 "Whether to enable OpenGL ES 2.0." PUBLIC ${ENABLE_GLES2_DEFAULT})
82 WEBKIT_OPTION_DEFINE(ENABLE_GTKDOC "Whether or not to use generate gtkdoc." PUBLIC OFF)
83 WEBKIT_OPTION_DEFINE(ENABLE_INTROSPECTION "Whether to enable GObject introspection." PUBLIC ON)
84 WEBKIT_OPTION_DEFINE(ENABLE_OPENGL "Whether to use OpenGL." PUBLIC ON)
85 WEBKIT_OPTION_DEFINE(ENABLE_PLUGIN_PROCESS_GTK2 "Whether to build WebKitPluginProcess2 to load GTK2 based plugins." PUBLIC ON)
86 WEBKIT_OPTION_DEFINE(ENABLE_QUARTZ_TARGET "Whether to enable support for the Quartz windowing target." PUBLIC ${GTK3_SUPPORTS_QUARTZ})
87 WEBKIT_OPTION_DEFINE(ENABLE_X11_TARGET "Whether to enable support for the X11 windowing target." PUBLIC ${GTK3_SUPPORTS_X11})
88 WEBKIT_OPTION_DEFINE(ENABLE_WAYLAND_TARGET "Whether to enable support for the Wayland windowing target." PUBLIC ${GTK3_SUPPORTS_WAYLAND})
89 WEBKIT_OPTION_DEFINE(USE_LIBNOTIFY "Whether to enable the default web notification implementation." PUBLIC ON)
90 WEBKIT_OPTION_DEFINE(USE_LIBHYPHEN "Whether to enable the default automatic hyphenation implementation." PUBLIC ON)
91 WEBKIT_OPTION_DEFINE(USE_LIBSECRET "Whether to enable the persistent credential storage using libsecret." PUBLIC ON)
92
93 # Private options specific to the GTK+ port. Changing these options is
94 # completely unsupported. They are intended for use only by WebKit developers.
95 WEBKIT_OPTION_DEFINE(USE_GSTREAMER_GL "Whether to enable support for GStreamer GL" PRIVATE ON)
96 WEBKIT_OPTION_DEFINE(USE_GSTREAMER_MPEGTS "Whether to enable support for MPEG-TS" PRIVATE OFF)
97 WEBKIT_OPTION_DEFINE(USE_REDIRECTED_XCOMPOSITE_WINDOW "Whether to use a Redirected XComposite Window for accelerated compositing in X11." PRIVATE ON)
98
99 # FIXME: Can we use cairo-glesv2 to avoid this conflict?
100 WEBKIT_OPTION_CONFLICT(ENABLE_ACCELERATED_2D_CANVAS ENABLE_GLES2)
101
102 WEBKIT_OPTION_DEPEND(ENABLE_3D_TRANSFORMS ENABLE_OPENGL)
103 WEBKIT_OPTION_DEPEND(ENABLE_ACCELERATED_2D_CANVAS ENABLE_OPENGL)
104 WEBKIT_OPTION_DEPEND(ENABLE_GLES2 ENABLE_OPENGL)
105 WEBKIT_OPTION_DEPEND(ENABLE_PLUGIN_PROCESS_GTK2 ENABLE_X11_TARGET)
106 WEBKIT_OPTION_DEPEND(ENABLE_WEBGL ENABLE_OPENGL)
107 WEBKIT_OPTION_DEPEND(USE_REDIRECTED_XCOMPOSITE_WINDOW ENABLE_OPENGL)
108 WEBKIT_OPTION_DEPEND(USE_REDIRECTED_XCOMPOSITE_WINDOW ENABLE_X11_TARGET)
109 WEBKIT_OPTION_DEPEND(USE_GSTREAMER_GL ENABLE_OPENGL)
110 WEBKIT_OPTION_DEPEND(USE_GSTREAMER_GL ENABLE_VIDEO)
111 WEBKIT_OPTION_DEPEND(USE_GSTREAMER_MPEGTS ENABLE_VIDEO)
112
113 SET_AND_EXPOSE_TO_BUILD(ENABLE_DEVELOPER_MODE ${DEVELOPER_MODE})
114 if (DEVELOPER_MODE)
115     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MINIBROWSER PUBLIC ON)
116     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_API_TESTS PRIVATE ON)
117 else ()
118     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MINIBROWSER PUBLIC OFF)
119     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_API_TESTS PRIVATE OFF)
120     if (NOT CMAKE_SYSTEM_NAME MATCHES "Darwin")
121         set(WebKit2_VERSION_SCRIPT "-Wl,--version-script,${CMAKE_MODULE_PATH}/gtksymbols.filter")
122     endif ()
123 endif ()
124
125 if (CMAKE_SYSTEM_NAME MATCHES "Linux")
126     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEMORY_SAMPLER PUBLIC ON)
127     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_RESOURCE_USAGE PRIVATE ON)
128 else ()
129     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEMORY_SAMPLER PUBLIC OFF)
130     WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_RESOURCE_USAGE PRIVATE OFF)
131 endif ()
132
133 # Public options shared with other WebKit ports. Do not add any options here
134 # without approval from a GTK+ reviewer. There must be strong reason to support
135 # changing the value of the option.
136 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ACCELERATED_2D_CANVAS PUBLIC OFF)
137 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DRAG_SUPPORT PUBLIC ON)
138 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_GEOLOCATION PUBLIC ON)
139 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ICONDATABASE PUBLIC ON)
140 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_JIT PUBLIC ON)
141 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SAMPLING_PROFILER PUBLIC ON)
142 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SPELLCHECK PUBLIC ON)
143 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_TOUCH_EVENTS PUBLIC ON)
144 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_VIDEO PUBLIC ON)
145 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_WEB_AUDIO PUBLIC ON)
146 WEBKIT_OPTION_DEFAULT_PORT_VALUE(USE_SYSTEM_MALLOC PUBLIC OFF)
147
148 # Private options shared with other WebKit ports. Add options here when
149 # we need a value different from the default defined in WebKitFeatures.cmake.
150 # Changing these options is completely unsupported.
151 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_3D_TRANSFORMS PRIVATE ON)
152 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_ACCESSIBILITY PRIVATE ON)
153 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_CANVAS_PATH PRIVATE OFF)
154 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_CSS_REGIONS PRIVATE ON)
155 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_CSS_SELECTORS_LEVEL4 PRIVATE ON)
156 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DATABASE_PROCESS PRIVATE ON)
157 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_DOWNLOAD_ATTRIBUTE PRIVATE ON)
158 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_FTPDIR PRIVATE OFF)
159 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_FULLSCREEN_API PRIVATE ON)
160 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_INDEXED_DATABASE PRIVATE ON)
161 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_INDEXED_DATABASE_IN_WORKERS PRIVATE ON)
162 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_INPUT_TYPE_COLOR PRIVATE ON)
163 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MEDIA_CONTROLS_SCRIPT PRIVATE ON)
164 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_MHTML PRIVATE ON)
165 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_NOTIFICATIONS PRIVATE ON)
166 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_PUBLIC_SUFFIX_LIST PRIVATE ON)
167 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_REMOTE_INSPECTOR PRIVATE ON)
168 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_SMOOTH_SCROLLING PRIVATE ON)
169 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_USERSELECT_ALL PRIVATE ON)
170 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_USER_MESSAGE_HANDLERS PRIVATE ON)
171 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_VIDEO_TRACK PRIVATE ON)
172 WEBKIT_OPTION_DEFAULT_PORT_VALUE(ENABLE_WEBGL PRIVATE ON)
173
174 # Finalize the value for all options. Do not attempt to use an option before
175 # this point, and do not attempt to change any option after this point.
176 WEBKIT_OPTION_END()
177
178 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_QUARTZ ${ENABLE_QUARTZ_TARGET})
179 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_X11 ${ENABLE_X11_TARGET})
180 SET_AND_EXPOSE_TO_BUILD(WTF_PLATFORM_WAYLAND ${ENABLE_WAYLAND_TARGET})
181
182 # MOZ_X11 and XP_UNIX are required by npapi.h. Their value is not checked;
183 # only their definedness is. They should only be defined in the true case.
184 if (${ENABLE_X11_TARGET})
185     SET_AND_EXPOSE_TO_BUILD(MOZ_X11 1)
186     SET_AND_EXPOSE_TO_BUILD(XP_UNIX 1)
187 endif ()
188
189 set(ENABLE_PLUGIN_PROCESS ${ENABLE_NETSCAPE_PLUGIN_API})
190
191 add_definitions(-DBUILDING_GTK__=1)
192 add_definitions(-DGETTEXT_PACKAGE="WebKit2GTK-${WEBKITGTK_API_VERSION}")
193 add_definitions(-DDATA_DIR="${CMAKE_INSTALL_DATADIR}")
194 add_definitions(-DUSER_AGENT_GTK_MAJOR_VERSION="604")
195 add_definitions(-DUSER_AGENT_GTK_MINOR_VERSION="1")
196 add_definitions(-DWEBKITGTK_API_VERSION_STRING="${WEBKITGTK_API_VERSION}")
197
198 set(GTK_LIBRARIES ${GTK3_LIBRARIES})
199 set(GTK_INCLUDE_DIRS ${GTK3_INCLUDE_DIRS})
200 set(GDK_LIBRARIES ${GDK3_LIBRARIES})
201 set(GDK_INCLUDE_DIRS ${GDK3_INCLUDE_DIRS})
202
203 SET_AND_EXPOSE_TO_BUILD(HAVE_GTK_GESTURES ${GTK3_SUPPORTS_GESTURES})
204 SET_AND_EXPOSE_TO_BUILD(HAVE_GTK_UNIX_PRINTING ${GTK_UNIX_PRINT_FOUND})
205
206 set(glib_components gio gio-unix gobject gthread gmodule)
207 find_package(GLIB 2.36 REQUIRED COMPONENTS ${glib_components})
208
209 if (ENABLE_XSLT)
210     find_package(LibXslt 1.1.7 REQUIRED)
211 endif ()
212
213 if (ENABLE_ACCELERATED_2D_CANVAS)
214     if (GLX_FOUND)
215         list(APPEND CAIROGL_COMPONENTS cairo-glx)
216     endif ()
217     if (EGL_FOUND)
218         list(APPEND CAIROGL_COMPONENTS cairo-egl)
219     endif ()
220
221     find_package(CairoGL 1.10.2 COMPONENTS ${CAIROGL_COMPONENTS})
222     if (NOT CAIROGL_FOUND)
223         message(FATAL_ERROR "CairoGL is needed for ENABLE_ACCELERATED_2D_CANVAS")
224     endif ()
225 endif ()
226
227 if (USE_LIBSECRET)
228     find_package(Libsecret)
229     if (NOT LIBSECRET_FOUND)
230         message(FATAL_ERROR "libsecret is needed for USE_LIBSECRET")
231     endif ()
232 endif ()
233
234 if (ENABLE_GAMEPAD_DEPRECATED)
235     find_package(GUdev)
236     if (NOT GUDEV_FOUND)
237         message(FATAL_ERROR "GUdev is needed for ENABLE_GAMEPAD_DEPRECATED")
238     endif ()
239 endif ()
240
241 if (ENABLE_GEOLOCATION)
242     find_package(GeoClue2 2.1.5)
243     if (GEOCLUE2_FOUND)
244         SET_AND_EXPOSE_TO_BUILD(USE_GEOCLUE2 ${GEOCLUE2_FOUND})
245     else ()
246         find_package(GeoClue)
247         if (NOT GEOCLUE_FOUND)
248             message(FATAL_ERROR "Geoclue is needed for ENABLE_GEOLOCATION.")
249         endif ()
250     endif ()
251 endif ()
252
253 if (ENABLE_INTROSPECTION)
254     find_package(GObjectIntrospection)
255     if (NOT INTROSPECTION_FOUND)
256         message(FATAL_ERROR "GObjectIntrospection is needed for ENABLE_INTROSPECTION.")
257     endif ()
258 endif ()
259
260 if (ENABLE_MEDIA_STREAM OR ENABLE_WEB_RTC)
261     find_package(OpenWebRTC)
262     if (NOT OPENWEBRTC_FOUND)
263         message(FATAL_ERROR "OpenWebRTC is needed for ENABLE_MEDIA_STREAM and ENABLE_WEB_RTC.")
264     endif ()
265     SET_AND_EXPOSE_TO_BUILD(USE_OPENWEBRTC TRUE)
266 endif ()
267
268 if (ENABLE_SUBTLE_CRYPTO)
269     find_package(Libtasn1 REQUIRED)
270     if (NOT LIBTASN1_FOUND)
271         message(FATAL_ERROR "libtasn1 is required to enable Web Crypto API support.")
272     endif ()
273     if (LIBGCRYPT_VERSION VERSION_LESS 1.7.0)
274         message(FATAL_ERROR "libgcrypt 1.7.0 is required to enable Web Crypto API support.")
275     endif ()
276     SET_AND_EXPOSE_TO_BUILD(USE_GCRYPT TRUE)
277 endif ()
278
279 SET_AND_EXPOSE_TO_BUILD(USE_TEXTURE_MAPPER TRUE)
280
281 if (ENABLE_OPENGL)
282     # ENABLE_OPENGL is true if either USE_OPENGL or ENABLE_GLES2 is true.
283     # But USE_OPENGL is the opposite of ENABLE_GLES2.
284     if (ENABLE_GLES2)
285         find_package(OpenGLES2 REQUIRED)
286         SET_AND_EXPOSE_TO_BUILD(USE_OPENGL_ES_2 TRUE)
287
288         if (NOT EGL_FOUND)
289             message(FATAL_ERROR "EGL is needed for ENABLE_GLES2.")
290         endif ()
291     else ()
292         if (NOT OPENGL_FOUND)
293             message(FATAL_ERROR "Either OpenGL or OpenGLES2 is needed for ENABLE_OPENGL.")
294         endif ()
295         SET_AND_EXPOSE_TO_BUILD(USE_OPENGL TRUE)
296     endif ()
297
298     if (NOT EGL_FOUND AND (NOT ENABLE_X11_TARGET OR NOT GLX_FOUND))
299         message(FATAL_ERROR "Either GLX or EGL is needed for ENABLE_OPENGL.")
300     endif ()
301
302     SET_AND_EXPOSE_TO_BUILD(ENABLE_GRAPHICS_CONTEXT_3D TRUE)
303
304     SET_AND_EXPOSE_TO_BUILD(USE_TEXTURE_MAPPER_GL TRUE)
305
306     SET_AND_EXPOSE_TO_BUILD(USE_EGL ${EGL_FOUND})
307
308     if (ENABLE_X11_TARGET AND GLX_FOUND AND USE_OPENGL)
309         SET_AND_EXPOSE_TO_BUILD(USE_GLX TRUE)
310     endif ()
311
312     SET_AND_EXPOSE_TO_BUILD(USE_COORDINATED_GRAPHICS TRUE)
313     SET_AND_EXPOSE_TO_BUILD(USE_COORDINATED_GRAPHICS_THREADED TRUE)
314 endif ()
315
316 if (ENABLE_PLUGIN_PROCESS_GTK2)
317     find_package(GTK2 2.24.10 REQUIRED)
318     find_package(GDK2 2.24.10 REQUIRED)
319 endif ()
320
321 if (ENABLE_SPELLCHECK)
322     find_package(Enchant)
323     if (NOT PC_ENCHANT_FOUND)
324         message(FATAL_ERROR "Enchant is needed for ENABLE_SPELLCHECK")
325     endif ()
326 endif ()
327
328 if (ENABLE_VIDEO OR ENABLE_WEB_AUDIO)
329     set(GSTREAMER_COMPONENTS app pbutils)
330
331     if (ENABLE_VIDEO)
332         list(APPEND GSTREAMER_COMPONENTS video mpegts tag gl)
333     endif ()
334
335     if (ENABLE_WEB_AUDIO)
336         list(APPEND GSTREAMER_COMPONENTS audio fft)
337     endif ()
338
339     find_package(GStreamer 1.2.3 REQUIRED COMPONENTS ${GSTREAMER_COMPONENTS})
340
341     if (ENABLE_WEB_AUDIO)
342         if (NOT PC_GSTREAMER_AUDIO_FOUND OR NOT PC_GSTREAMER_FFT_FOUND)
343             message(FATAL_ERROR "WebAudio requires the audio and fft GStreamer libraries. Please check your gst-plugins-base installation.")
344         else ()
345             SET_AND_EXPOSE_TO_BUILD(USE_WEBAUDIO_GSTREAMER TRUE)
346         endif ()
347     endif ()
348
349     if (ENABLE_VIDEO)
350         if (NOT PC_GSTREAMER_APP_FOUND OR NOT PC_GSTREAMER_PBUTILS_FOUND OR NOT PC_GSTREAMER_TAG_FOUND OR NOT PC_GSTREAMER_VIDEO_FOUND)
351             message(FATAL_ERROR "Video playback requires the following GStreamer libraries: app, pbutils, tag, video. Please check your gst-plugins-base installation.")
352         endif ()
353     endif ()
354
355     if (USE_GSTREAMER_MPEGTS)
356         if (NOT PC_GSTREAMER_MPEGTS_FOUND)
357             message(FATAL_ERROR "GStreamer MPEG-TS is needed for USE_GSTREAMER_MPEGTS.")
358         endif ()
359     endif ()
360
361     if (USE_GSTREAMER_GL)
362         if (PC_GSTREAMER_VERSION VERSION_LESS "1.10")
363             set(USE_GSTREAMER_GL OFF)
364             message(STATUS "Disabling GSTREAMER_GL as the GStreamer version is older than 1.10.")
365         else ()
366             if (NOT PC_GSTREAMER_GL_FOUND)
367                 message(FATAL_ERROR "GStreamerGL is needed for USE_GSTREAMER_GL.")
368             endif ()
369         endif ()
370     endif ()
371
372     SET_AND_EXPOSE_TO_BUILD(USE_GSTREAMER TRUE)
373 endif ()
374
375 if (ENABLE_QUARTZ_TARGET)
376     if (NOT GTK3_SUPPORTS_QUARTZ)
377         message(FATAL_ERROR "Recompile GTK+ with Quartz backend to use ENABLE_QUARTZ_TARGET")
378     endif ()
379 endif ()
380
381 if (ENABLE_X11_TARGET)
382     if (NOT GTK3_SUPPORTS_X11)
383         message(FATAL_ERROR "Recompile GTK+ with X11 backend to use ENABLE_X11_TARGET")
384     endif ()
385
386     find_package(X11 REQUIRED)
387     if (NOT X11_Xcomposite_FOUND)
388         message(FATAL_ERROR "libXcomposite is required for ENABLE_X11_TARGET")
389     elseif (NOT X11_Xdamage_FOUND)
390         message(FATAL_ERROR "libXdamage is required for ENABLE_X11_TARGET")
391     elseif (NOT X11_Xrender_FOUND)
392         message(FATAL_ERROR "libXrender is required for ENABLE_X11_TARGET")
393     elseif (NOT X11_Xt_FOUND)
394         message(FATAL_ERROR "libXt is required for ENABLE_X11_TARGET")
395     endif ()
396 endif ()
397
398 if (ENABLE_WAYLAND_TARGET)
399     if (NOT GTK3_SUPPORTS_WAYLAND)
400         message(FATAL_ERROR "Recompile GTK+ with Wayland backend to use ENABLE_WAYLAND_TARGET")
401     endif ()
402
403     if (GTK3_VERSION VERSION_LESS 3.12)
404         message(FATAL_ERROR "GTK+ 3.12 is required to use ENABLE_WAYLAND_TARGET")
405     endif ()
406
407     if (NOT EGL_FOUND)
408         message(FATAL_ERROR "EGL is required to use ENABLE_WAYLAND_TARGET")
409     endif ()
410
411     find_package(Wayland REQUIRED)
412 endif ()
413
414 if (USE_LIBNOTIFY)
415     find_package(LibNotify)
416     if (NOT LIBNOTIFY_FOUND)
417        message(FATAL_ERROR "libnotify is needed for USE_LIBNOTIFY.")
418     endif ()
419 endif ()
420
421 if (USE_LIBHYPHEN)
422     find_package(Hyphen)
423     if (NOT HYPHEN_FOUND)
424        message(FATAL_ERROR "libhyphen is needed for USE_LIBHYPHEN.")
425     endif ()
426 endif ()
427
428 # Override the cached variables, gtk-doc and gobject-introspection do not really work when cross-building.
429 if (CMAKE_CROSSCOMPILING)
430     set(ENABLE_GTKDOC OFF)
431     set(ENABLE_INTROSPECTION OFF)
432 endif ()
433
434 # Override the cached variable, gtk-doc does not really work when building on Mac.
435 if (APPLE)
436     set(ENABLE_GTKDOC OFF)
437 endif ()
438
439 set(DERIVED_SOURCES_WEBKITGTK_DIR ${DERIVED_SOURCES_DIR}/webkitgtk)
440 set(DERIVED_SOURCES_WEBKITGTK_API_DIR ${DERIVED_SOURCES_WEBKITGTK_DIR}/webkit)
441 set(DERIVED_SOURCES_WEBKIT2GTK_DIR ${DERIVED_SOURCES_DIR}/webkit2gtk)
442 set(DERIVED_SOURCES_WEBKIT2GTK_API_DIR ${DERIVED_SOURCES_WEBKIT2GTK_DIR}/webkit2)
443 set(FORWARDING_HEADERS_WEBKIT2GTK_DIR ${FORWARDING_HEADERS_DIR}/webkit2gtk)
444 set(FORWARDING_HEADERS_WEBKIT2GTK_EXTENSION_DIR ${FORWARDING_HEADERS_DIR}/webkit2gtk-webextension)
445
446 set(WebKit_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/WebKitLegacy/gtk/webkitgtk-${WEBKITGTK_API_VERSION}.pc)
447 set(WebKit2_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/WebKit/webkit2gtk-${WEBKITGTK_API_VERSION}.pc)
448 set(WebKit2WebExtension_PKGCONFIG_FILE ${CMAKE_BINARY_DIR}/Source/WebKit/webkit2gtk-web-extension-${WEBKITGTK_API_VERSION}.pc)
449
450 set(SHOULD_INSTALL_JS_SHELL ON)
451
452 # Add a typelib file to the list of all typelib dependencies. This makes it easy to
453 # expose a 'gir' target with all gobject-introspection files.
454 macro(ADD_TYPELIB typelib)
455     if (ENABLE_INTROSPECTION)
456         get_filename_component(target_name ${typelib} NAME_WE)
457         add_custom_target(${target_name}-gir ALL DEPENDS ${typelib})
458         list(APPEND GObjectIntrospectionTargets ${target_name}-gir)
459         set(GObjectIntrospectionTargets ${GObjectIntrospectionTargets} PARENT_SCOPE)
460     endif ()
461 endmacro()
462
463 # CMake does not automatically add --whole-archive when building shared objects from
464 # a list of convenience libraries. This can lead to missing symbols in the final output.
465 # We add --whole-archive to all libraries manually to prevent the linker from trimming
466 # symbols that we actually need later. With ld64 on darwin, we use -all_load instead.
467 macro(ADD_WHOLE_ARCHIVE_TO_LIBRARIES _list_name)
468     if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
469         list(APPEND ${_list_name} -Wl,-all_load)
470     else ()
471         foreach (library IN LISTS ${_list_name})
472           list(APPEND ${_list_name}_TMP -Wl,--whole-archive ${library} -Wl,--no-whole-archive)
473         endforeach ()
474         set(${_list_name} "${${_list_name}_TMP}")
475     endif ()
476 endmacro()