[WPE] run-qt-wpe-minibrowser needlessly expects a --wpe argument
[WebKit-https.git] / LayoutTests / platform / ipad / media / modern-media-controls / media-documents / media-document-audio-ios-sizing.html
1 <script src="../../../../../resources/js-test-pre.js"></script>
2 <meta name="viewport" content="width=device-width, initial-scale=1">
3 <body>
4 <iframe src="../../../../../media/content/silence.mp3" style="position: absolute; top: 0; left: 0; width: 100%; height: 100%;"></iframe>
5 <script type="text/javascript">
6
7 description("Testing the size of the media element in an audio media document on iOS.");
8
9 window.jsTestIsAsync = true;
10
11 let media;
12
13 (function runTestIfReady() {
14     const iframe = document.querySelector("iframe");
15     media = iframe.contentDocument.querySelector("video");
16
17     if (!media) {
18         setTimeout(runTestIfReady);
19         return;
20     }
21
22     shouldBecomeEqualToString("getComputedStyle(media).width", "650px", () => {
23         shouldBeEqualToString("getComputedStyle(media).height", "50px");
24
25         debug("");
26         iframe.remove();
27         finishJSTest();
28     });
29
30 })();
31
32 </script>
33 <script src="../../../../../resources/js-test-post.js"></script>
34 </body>