[WPE] run-qt-wpe-minibrowser needlessly expects a --wpe argument
[WebKit-https.git] / LayoutTests / platform / ipad / fast / forms / focus-input-via-button.html
1 <!DOCTYPE html> <!-- webkit-test-runner [ useFlexibleViewport=true ] -->
2
3 <html>
4 <head>
5     <meta name="viewport" content="initial-scale=1.5">
6     <style>
7         input[type="text"] {
8             margin: 800px 20px;
9         }
10         button {
11             display: block;
12         }
13     </style>
14     
15     <script src="../../../../fast/forms/ios/resources/zooming-test-utils.js"></script>
16     <script>
17     if (window.testRunner) {
18         testRunner.dumpAsText();
19         testRunner.waitUntilDone();
20     }
21     
22     function buttonClicked()
23     {
24         document.getElementById('input').focus();
25     }
26
27     function doTest()
28     {
29         testZoomAfterTap(document.getElementById('target'), 10, 10);
30     }
31
32     window.addEventListener('load', doTest, false);
33     </script>
34 </head>
35 <body>
36
37 <p>Tests zooming into a text input on tap.</p>
38 <button id="target" onclick="buttonClicked()">Click to focus input</button>
39
40 <input id="input" type="text">
41
42 </body>
43 </html>