[Mac] some track language tags are not recognized
[WebKit-https.git] / LayoutTests / media / track / track-webvtt-tc002-bom.html
1 <!DOCTYPE html>
2 <html>
3     <head>
4         <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
5
6         <script src=../media-file.js></script>
7         <script src=../video-test.js></script>
8         <script>
9             
10             function trackLoaded()
11             {
12                 findMediaElement();
13                 var expected = 
14                 {
15                     length : 2,
16                     tests:
17                     [
18                         {
19                             property : "id",
20                             values : [1, 2],
21                         },
22                         {
23                             property : "startTime",
24                             values : [0.0, 31.0],
25                         },
26                         {
27                             property : "endTime",
28                             values : [30.5, 1200.5],
29                         },
30                         {
31                             property : "text",
32                             values : ["Bear is Coming!!!!!", "I said Bear is coming!!!!"],
33                         },
34                     ],
35                 };
36                 testCues(0, expected);
37
38                 endTest();
39             }
40
41             setCaptionDisplayMode('Automatic');
42         </script>
43     </head>
44     <body>
45         <p>Tests that the parser properly ignores a UTF-8 BOM character at the beginning of a file and all other cues are properly parsed.</p>
46         <video>
47             <track src="captions-webvtt/tc002-bom.vtt" onload="trackLoaded()" default>
48         </video>
49     </body>
50 </html>