Moved previous link error fix to Base.xcconfig
[WebKit-https.git] / ANGLE / Configurations / Base.xcconfig
1 DEAD_CODE_STRIPPING = YES;
2 DEBUG_INFORMATION_FORMAT = dwarf;
3 GCC_C_LANGUAGE_STANDARD = gnu99;
4 GCC_DEBUGGING_SYMBOLS = default;
5 GCC_ENABLE_CPP_EXCEPTIONS = NO;
6 GCC_ENABLE_CPP_RTTI = NO;
7 GCC_ENABLE_OBJC_EXCEPTIONS = YES;
8 GCC_ENABLE_OBJC_GC = supported;
9 GCC_ENABLE_SYMBOL_SEPARATION = NO;
10 GCC_FAST_OBJC_DISPATCH = YES;
11 GCC_MODEL_TUNING = G5;
12 GCC_OBJC_CALL_CXX_CDTORS = YES;
13 GCC_OPTIMIZATION_LEVEL = s;
14 GCC_PRECOMPILE_PREFIX_HEADER = NO;
15 GCC_INLINES_ARE_PRIVATE_EXTERN = YES;
16 GCC_SYMBOLS_PRIVATE_EXTERN = NO;
17 GCC_THREADSAFE_STATICS = NO;
18 GCC_TREAT_WARNINGS_AS_ERRORS = NO;
19 GCC_WARN_ABOUT_DEPRECATED_FUNCTIONS = NO;
20 LINKER_DISPLAYS_MANGLED_NAMES = YES;
21 PREBINDING = NO;
22 STRIP_INSTALLED_PRODUCT = NO;
23
24
25 TARGET_MAC_OS_X_VERSION_MAJOR = $(MAC_OS_X_VERSION_MAJOR);
26
27
28 // Use GCC 4.2 with Xcode 3.1, which includes GCC 4.2 but defaults to GCC 4.0.
29 // Note that Xcode versions as new as 3.1.2 use XCODE_VERSION_ACTUAL for the minor version
30 // number.  Newer versions of Xcode use XCODE_VERSION_MINOR for the minor version, and
31 // XCODE_VERSION_ACTUAL for the full version number.
32 TARGET_GCC_VERSION = $(TARGET_GCC_VERSION_$(TARGET_MAC_OS_X_VERSION_MAJOR));
33 TARGET_GCC_VERSION_ = $(TARGET_GCC_VERSION_1040);
34 TARGET_GCC_VERSION_1040 = GCC_40;
35 TARGET_GCC_VERSION_1050 = $(TARGET_GCC_VERSION_1050_$(XCODE_VERSION_MINOR));
36 TARGET_GCC_VERSION_1050_ = $(TARGET_GCC_VERSION_1050_$(XCODE_VERSION_ACTUAL));
37 TARGET_GCC_VERSION_1050_0310 = GCC_42;
38 TARGET_GCC_VERSION_1050_0320 = GCC_42;
39 TARGET_GCC_VERSION_1060 = GCC_42;
40 TARGET_GCC_VERSION_1070 = LLVM_GCC_42;
41
42 GCC_VERSION = $(GCC_VERSION_$(TARGET_GCC_VERSION));
43 GCC_VERSION_GCC_40 = 4.0;
44 GCC_VERSION_GCC_42 = 4.2;
45 GCC_VERSION_LLVM_GCC_42 = com.apple.compilers.llvmgcc42;
46
47 // If the target Mac OS X version does not match the current Mac OS X version then we'll want to build using the target version's SDK.
48 SDKROOT = $(SDKROOT_$(MAC_OS_X_VERSION_MAJOR)_$(TARGET_MAC_OS_X_VERSION_MAJOR));
49 SDKROOT_1050_1040 = macosx10.4internal;
50 SDKROOT_1060_1040 = macosx10.4internal;
51 SDKROOT_1060_1050 = macosx10.5internal;
52 SDKROOT_1070_1040 = macosx10.4internal;
53 SDKROOT_1070_1050 = macosx10.5internal;
54 SDKROOT_1070_1060 = macosx10.6internal;